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© Copyright 2024 Datamine Software 

All Rights Reserved 

Confidential and Proprietary 

 

Legal Disclaimer 

The product described in this documentation may be connected to, and/or communicate 

information and data via, a network interface, which should be connected to a secure network. It is 

your sole responsibility to ensure a secure connection to the network and to establish and maintain 

appropriate measures (such as but not limited to the installation of firewalls, application of 

authentication measures, encryption of data, installation of antivirus programs, etc.) to protect the 

product, the network, your systems, and the interface against any kind of security breach, 

unauthorised access, interference, intrusion, leakage, damage, or corruption or theft of data. We are 

not liable for damages or losses related to any such security breach, unauthorised access, 

interference, intrusion, leakage, damage, or corruption or theft of data. 
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What’s New 

Discover the latest enhancements and additions introduced in MineScape 

Update 3. 

IMPORTANT: Before installing MineScape 2023 Update 3, users must update the 

System Service to the latest version through the Distribution Portal. This update is 

required to ensure a smooth installation process and optimal performance of the 

MineScape software. Attempting to install MineScape without first updating the 

System Service will result in installation issues. 

Watershed Analysis 

The new Watershed Analysis App allows users to visualise water flow from 

existing terrain data. It includes an integrated Mesh Smoothing feature to 

enhance the clarity of flow direction arrows and an Elevation Heatmap to display 

height differences in the terrain, helping users quickly understand the 

landscape’s shape and slopes. 

This feature comes as a standalone app within the Surface Engineering Product. 

Once loaded, it can be accessed through either the Watershed Analysis App or 

the Open Cut App. 

 
Watershed Layers and Textures 

https://central.minescapesoftware.com/software
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New Send Query System 

Users can now directly send queries from MineScape via the new Send Query 

Button, accessible within the Help Tab. This update provides a form for users to 

write their issues, suggestions, or feedback and send it to our support team. This 

enhancement streamlines the support process, making it easier and faster for 

users to communicate with our team without having to exit MineScape. 

 

The form also allows users to attach files up to 5 MB in size. Supported file types 

are: 

• ASCII: .ASC, .DAT, .CSV, and .TXT 

• Video: .MP4, .AVI, .MOV, .WMV, .FLV, .MKV 

• Image: JPG, .JPEG, .PNG, .BMP 

NOTE: Internet connectivity is required to use this functionality. 

 
New Send Query Form 
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CAD 

Support for Deswik Import 

Users can import Deswik files to MineScape. Files can be imported as either 

design data or mesh. For design data (.dgn), only lines, polygons and colours are 

currently supported. 

 
New Deswik Import Option as Design Data 

 
New Deswik Import Option as Mesh 
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Improved Statistics Dock 

Users can now view the total area and total length in the Statistics Dock of all 

selected elements in the CAD Window after clicking Run. Previously, this 

information was only available for single-element selections. The Area calculation 

applies only to POLYGON and DESIGNPOLYGON element types, as lines do not 

have an "inside area." Additionally, the Area View value updates after rotating 

elements and clicking Run again.  

NOTE: Currently only elements with LINES, DESIGNLINE, POLYGON, and 

DESIGNPOLYGON types are supported. 

 
Total Area and Total Length Information of All Selected Elements 

Nomenclature Change in RapidCAD 

Changed the option texts in the confirmation dialog box that appears after 

clicking the Extend to Intersection Option in RapidCAD. 
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Updated Option Texts 

New Validation for Removing Self-Intersection 

Added a confirmation message for the Remove Self-Intersection Option, 

accessible in the Design Tab under the Repair Data Dropdown Menu, that 

appears when users select line elements with start and end vertices that overlap 

too closely. If the minimum segment length of the resulting elements is less than 

0.0001, the confirmation message below will appear. This prevents confusion 

where lines with overlapping vertices might be mistaken for polygons. 

 
A Confirmation Message for Self-Intersection Option 

Added Multi-Line Expression Capability 

Users can now input multi-line expressions directly into the Surface Form when 

creating or updating an expression surface, eliminating the legacy requirement of 

linking the expression to an MXL file. 

The Surface Form is accessible by navigating to Definitions » Surfaces » 

Expression in the MineScape in the MineScape Explorer. 
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Surface Form with a Multi-Line Expression 

Improved Surface Inspector Feature 

Users can now obtain elevation values of one or multiple surfaces simultaneously, 

without having to load the surfaces on the CAD Window. The Surface Inspector 

Option is accessible from the Analyse Tab of the CAD App.  

 
Surface Inspector Option 

There are two types of modes – Dynamic and Manual. 

The Dynamic Mode allows users to hover the cursor anywhere on the CAD 

Window and the Display Surface Form will display the elevation values in real-

time.  
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Display Surface Form in Dynamic Mode 

The Manual Mode allows users to input specific coordinates (X and Y values) and 

the Display Surface Form will display the elevation values of the specified 

coordinates.  

 
Display Surface Form in Manual Mode 

Other CAD Enhancements 

• Added the ESRI Shape File as an import option when right-clicking on a 

design file and selecting Import From Option. 
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• Added the Connect intersected segments Checkbox in the Segments 

Group of the Design Tab. When ticked, MineScape merges two segments 

into one after they intersect. 

 
Connect intersected segments checkbox 

• Added the grade switcher in the Measure Dock that is similar to the one in 

the Statistics Dock. 

Mesh 

Mesh Smoothing 

Users can now improve mesh surfaces by reducing irregularities and noise, such 

as those from LiDAR scanners, with the new Mesh Smoothing Option. This tool 

enhances visual clarity in applications like watershed analysis by refining 

elements like flow direction arrows. Users can either generate a new mesh as the 

output or override an existing one. 

NOTE: Keep in mind that this feature will copy the mesh texture and metadata 

into the output mesh, but it will not retain point colours. 

To access this option, go to the Mesh Tab in the CAD App. Locate the Graphics 

Group and select Smooth. 
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Mesh Smoothing 

Expanded Element Type Support in the Relimit Function 

Users can now use any element type from the polygon class as a boundary 

polygon, expanding beyond polygon-type elements. This update applies to the 

Relimit Boundary Section in the Create Surface Form and the Relimit Section in 

the Create Mesh by Polygons Form. Both forms are accessible under the Surface 

Mesh Group within the Mesh Tab, which is available in both the CAD Ribbon and 

the Point Cloud Tools Ribbon. 

 
Surface Mesh Group within the Mesh Tab 

Added “New Definition” Option  

A New Definition Option has been added when right-clicking a mesh file under 

the Mesh Node in the Explorer Dock. This opens the Mesh Surface Definition 

Form, which is the same form accessed from the Definition >> Surfaces Node, 

but with the Mesh Group and Mesh File fields pre-populated. Once created, the 
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new Mesh Surface Definition will be stored under Definition >> Surfaces >> Mesh 

in the Explorer Dock.  

 
Mesh Surface Definition Form 

Improved the Mesh from Point Cloud Feature 

Added a Create Mesh Surface Definition Checkbox to the Create Mesh from 

Point Cloud Form to simplify the mesh creation process. Users can now create 

mesh surface definitions directly from the form, while the option to manually 

create them through the MineScape Explorer remains available.  
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Improved mesh from point cloud feature 

Reserves 

Run underground reserves from Across MineScape Apps 

Starting from this update, UG Multi-Mesh is added as a sample source in the Run 

Reserves, Model Resource, and Multipart Reserves Forms. This way, users can 

calculate reserves and volumes for underground mining blocks from across all 

MineScape applications.  

This form can be accessed from: 

• Open Cut > Reserves > Engineering > Run Reserves/Multipart Reserves 

• Open Cut > Reserves > Geology > Model Resource 

• UG Coal > Reserves > Run Reserves/Multipart Reserves 

• Stratmodel > Reserves > Engineering > Run Reserves/Multipart 

Reserves 

• Stratmodel > Reserves > Geology > Model Resource 
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Geology 

Nomenclature Change in GDB’s 2D and 3D Graphics Forms 

Changed the CAD Apply Button to Apply in the Drill Hole 2D Graphics and Drill 

Graphics Forms. The CAD Apply previously stowed the form, whereas the 

updated button will no longer stow the form. 

Added the Statistics Tab in the Interval Summary Report 

Accessible through the Reports Tab of the GDB App, users can generate the 

Interval Summary Report via the Logs Option. Upon generation, there will be a 

new addition of a second Statistics Tab in the output spreadsheet file.  
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Statistics Tab of the Interval Summary Report 

Basic Interval Data Retrieval  

Added the Basic Interval Data Retrieval Option, which allows users to retrieve 

drillhole and interval data from the database and put it in a table file. The Basic 

Interval Data Retrieval Form can be accessed through the Reports Tab of the 

GDB App.  

 
Input/Output Tab of the Basic Interval Data Retrieval Form 
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Retrieval Items Tab of the Basic Interval Data Retrieval Form 

Lithological Data Retrieval 

Added the Lithological Data Retrieval Option, which allows users to generate an 

output table file containing geometrical and lithological information of the 

geological environment. The Lithological Data Retrieval Form can be accessed 

through the Reports Tab of the GDB App.  

 
Input/Output Tab of the Lithological Data Retrieval Form 
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Top Limit Tab of the Lithological Data Retrieval Form 

 
Bottom Limit Tab of the Lithological Data Retrieval Form 
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Retrieval Items Tab of the Lithological Data Retrieval Form 

Scheduling 

Limit Output Lines 

The Limit Output Lines Field has been added to the Generate by Progress and 

Generate by Periods Forms allowing users to apply the limit output lines only to 

the scheduled blocks. 

 
Generate by Progress Form 
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Generate by Period Form 

Surface Engineering 

Improved Rapid Slicer for More Usability 

MineScape’s Rapid Slicer Tool has been improved in the following ways: 

• Added the Apply Button in the Settings Dialog Box so that users can now 

apply a new angle to all slicer lines simultaneously, regardless if they are 

horizontal or vertical 

• Effortlessly adjust the rotation angle by entering the exact degree in the 

Rapid Slicer Toolbox, providing an alternative to the Rotation Handle 

 

Rapid Slicer Toolbox Now Features Effortlessly Adjustable Rotation  
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This enhancement also accommodates decimal values, offering a customisable 

decimal place setting. 

 
Rotation Supports Adjustable Decimal Places 

Pit Optimization Pro 

The Pit Optimization Pro App has been enhanced in the following ways: 

Added Automatic Price Calculation  

 
Pit Opt Pro now supports automatic Price Per Iteration 
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Pit Optimization Pro now automatically calculates the Price per Iteration based 

on enhanced attributes such as Price Factor, Iterations, Rounding Factor, and 

Reference Price to replace Lower and Upper Prices, ensuring a hassle-free and 

efficient pit optimization experience.  

 
Enhanced Attributes on Price 

NOTE: The new price factor calculation is only applicable starting from MineScape 

2023 Update 3. 

Added Excel File for Price per Iteration 

Effortlessly run price simulations for each iteration with the provided Excel file. 

Users can easily adjust Minimum and Maximum Price Factors, set the number of 

Iterations, and input the Reference Price to see dynamic pricing for each 

iteration. 

 
View Button 
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Calculate Price Simulation with the provided Excel File 

Added Mining Recovery Expression  

 

Interval/Quality has been enhanced with Mining Recovery % Expression 

Pit Optimization Pro has been enhanced with Mining Recovery Expression to 

calculate resource loss, which is considered a burden instead of a mining cost for 

accurate calculation, ensuring precise recoverable resources and revenue 

estimation.  

 
Revenue Comparison  
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Added Classification in Reserves  

A  new Classification Node has been added to the Pit Optimization Pro Form so 

that users can incorporate resource classification into the pit optimization 

process.  

 
Classification is now available in the Pit Optimization Form 

Nomenclature Change 

Changed the name of Recovery (used to calculate the extractable volume of coal 

and overburden ) to Process Recovery. 

Underground Engineering 

Revamped the Tabs in the UG Coal Ribbon 

Reordered the tabs in the UG Coal Ribbon so now they are divided into Longwall, 

Pillars, Entries, Reserves and Subsidence. Most options in the old UG Coal Tab 

has been moved to different tabs. 
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UG Coal Ribbon – Before 

 
UG Coal Ribbon - After 

• The old UG Coal Tab has been renamed to Longwall 

• Added Solid/Outline Option in both the Longwall and Pillars Tabs. It’s 

helpful to toggle between displaying or hiding mining blocks outlines for 

better viewing of the bences, slices, and intervals. Similar functionality is 

found in the Mining Blocks App 

• The Create UG Solids Form has been merged into the Longwall Layout 

Form, accessible by selecting Create in the Longwall Tab. This update 

provides a smoother workflow by enabling users to generate longwall 

layouts and UG mining blocks in one simple form. 

 
Before – Longwall and UG Mining Blocks Creation in Two Separate Forms 
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After – Longwall and UG Mining Blocks Creation in One Form 

• The Run Reserves Option (previously located in UG Coal » UG Solids » Run 

Reserves) is now removed. Users can calculate volumes and reserves for 

UG Mining Blocks by going to the Reserves Tab and select Run Reserves 

Revamped the Form for Longwall Layout Creation 

The Automatically Generate a Longwall Layout Form has been enhanced in the 

following ways: 

• Ability for users to create scenario-based configuration. The UG scenario is 

saved as a .UGSCEN extension within the Specs Folder of the MineScape 

project. 

• UG mining blocks generation now outputs pillar mesh 

• Users can now choose to generate UG mining blocks from road or division 

layer 

• When generating UG mining blocks from a division layer, the recovery rate 

is written to the metadata as UGRECOVERY, which is useful for scheduling 

at a later time. The recovery rate represents the mineable area, which is the 
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portion of polygon blocks not covered by pillars. For longwall areas, the 

recovery rate is always 100%.  

 
UGRECOVERY Metadata 

With this update, the recovery data will be taken into account when 

calculating underground reserves in the Run Reserves Form.  

Generate Mining Blocks for Room and Pillar Method 

Added the Create Option in the Pillars Tab to allow users generate UG mining 

blocks for the Room and Pillar method. This option is similar to the UG Mining 

Blocks section in the Automatically Generate a Longwall Layout Form 
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Create UG Mining Blocks Form for Room and Pillar Method 

Plot Designer 

Improvements to Page Setup and Layout Features 

Plot Designer’s user interface and page management features have been 

updated, streamlining access to page settings and improving paper size and 

margin adjustments. 

• A new group called Page Setup is now available in the Plotting Tab, 

containing individual options that were previously managed within the 

Page Setup Form 
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Page Setup Group in Plotting Tab 

• The option to change page orientation is now also accessible from the 

Plotting Tab. Previously it was only available in the Plot Designer Toolbar. 

• The size of a Paper Window can now be updated. When the paper size 

changes, containers within the Paper Window may be resized and 

repositioned to maintain the layout as closely as possible. Previously, users 

had to create a new plot file with a new paper size. 

• The Restrict Data to Margins Option now affects margin updates, whereas 

previously it only applied when creating a new viewport. When enabled, 

containers are automatically repositioned and may be resized to fit within 

the new margins. 

 

Bug Fixes 

System Services 

• Fixed an issue where MineScape could not be installed due to outdated 

.NET Desktop Runtime version. MineScape System Services has now been 

updated to using .NET Desktop Runtime version 6.0.29. 

Core 

• Fixed an issue where MineScape notification pop-ups in a multi-monitor 

environment would appear on the other monitor instead of the monitor 

where the MineScape main window is located 
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CAD 

• Fixed an issue in the Height Cue Form where selecting pastel colour 

palette would revert back to CAD colours 

• Fixed an issue where Surface Inspector was unable to inspect mesh 

surfaces 

• Fixed an issue where the the Height Cue colours were not properly applied 

on a multi-mesh after clicking Apply 

• Fixed an issue where selecting only one colour on the Height Cue Form 

would cause the selection to become stuck, allowing the selection of three 

colours 

• Fixed an issue where the selecting Grade to Boundary through RapidCAD 

would display the Extend Interactive/Extend All Confirmation Dialog Box 

• Fixed performance issue when loading and unloading layers in CAD 

• Fixed a display issue where several tooltips showed different texts than the 

actual button functions 

• Fixed an issue where Surface Inspector couldn’t be accessed from the 

History context menu from the CAD Window 

• Fixed an issue where the Create Mesh and Filter Options in the Point 

Cloud Group of the Mesh Tab were disabled even though a point cloud file 

had been loaded onto the CAD Window 

• Fixed an issue where Surface Inspector didn’t mark invalid surfaces 

properly in the Display Surface Form 

• Fixed an issue where compound surfaces weren’t listed in the Surface 

Inspector Form 

Mesh 

• Fixed an error that occurred when trying to update a Digital Terrain Model 

(DTM) using an existing mesh 
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• Fixed an error where mesh couldn’t be created using the Create Mesh 

from Layer Form because the Mesh Group Field was left blank 

• Fixed an issue where creating a surface mesh using the Between Crest 

and Toe Option would not automatically refresh the output mesh if it was 

already loaded in the CAD Window. MineScape now detects if the output 

mesh is open and refreshes it accordingly. 

• Fixed an issue where the Create Mesh Surface Definition Checkbox was 

disabled in the Save Mesh Form 

• Fixed an issue where mesh definition wasn’t created after restoring a form 

spec in the Create Mesh by Polygons Form 

• Fixed an issue where users were unable to create a mesh using polygons 

due to manually inputted polygon IDs. The Polygon ID Column in the 

Create Mesh by Polygons Form is now set to read-only. Users must use 

the Pick Polygons Button or right-click and select Pick to input the 

polygon ID.  

• Fixed an issue where users were unable to input design file and layer 

names in the Create Mesh from Layer Form 

• Fixed an issue where mesh couldn’t be created when using the Relimit All 

– Delete Inside Option in the Create Mesh by Polygons Form 

• Fixed an issue where the statistics data disappeared when the mesh was 

loaded from the Display Dock  

Block Model 

• Fixed an issue where the Zone Column for an interval didn’t automatically 

get filled in when setting up a new block model 

• Fixed an issue where an error message was displayed after clicking 

Information from the right-click menu on a block model file in the 

Explorer Node 

• Fixed an issue where the Length Fields were not disabled after the 

Generate Extents Button was clicked in the Size & Orientation Form 
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• Fixed an issue where MineScape failed to generate surface grids through a 

block model due to a limitation of only 10 grid value inputs. MineScape can 

now handle up to 2000 inputs in a single process. 

GDB 

• Fixed an issue where selecting the Lithology Type Radio Button through 

Correlate > Insert/Replace Option showed interval names instead of 

lithology names 

Stratmodel 

• Fixed an issue where clicking the Adjust Button in the Edit a Drill Hole 

Form caused an Interval record to disappear due to an invalid sorting index 

when multiple Depth From values were similar. The sorting method has 

been updated to account for both Depth From and Depth To values.  

• Fixed a performance issue that occurred when generating a section 

through a schema 

• Fixed an issue in the Run Reserves Form where coal was not detected as 

resource in the result table when the Honour Triangles Checkbox in the 

Settings Node was ticked  

Surface Engineering 

• Fixed an issue where the Rapid Slicer box could be hidden and show 

vertices  

• Fixed an issue where the node label still said Bench Blocks in the Explorer 

Node instead of Mining Blocks 

• Fixed an issue where the Projection module failed due to incorrect strip 

naming when switching between 9 and 10 characters. The naming is now 

properly assigned, and the layer opens correctly after projection.  

• Fixed an issue where the Rapid Slicer grid wasn’t displayed after 

performing dynamic slicing on a single-bench mining block  
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• Fixed an issue where the Rapid Slicer Tool couldn’t slice a mining block 

with top and bottom surfaces 

• Fixed an issue where slicing multi-bench mining blocks with Rapid Slicer 

resulted in incorrect strip name assignment  

• Fixed an issue where MineScape displayed incorrect error message 

because the polygon layer name was missing 

• Fixed an error that occurred when generating a dump mesh 

• Fixed an issue in the Mining Blocks to DTM Form where the Mesh Name 

Dropdown list didn’t show any mesh block names based on the selected 

scenario  

• Fixed an issue where the routput engineering solid meshes were truncated 

because the input data was trimmed incorrectly 

• Fixed an error that occurred when trying to perform the Do Strip operation 

in the Dragline Application 

• Fixed an issue where selecting the Project Down Radio Button in the 

Generate Solids Form resulted in incorrect projection 

Scheduling 

• Fixed an issue where the sequence number and the associated block 

metadata were not automatically removed from the scheduling database 

when deleting multiple sequences 

• Fixed an issue where pit face positions couldn’t be generated by progress 

• Fixed an issue where the controls of the Constraints, Mine Map and 

Activity Map Windows were hidden behind the CAD Window 

• Fixed an issue where a blank error message appeared after picking a block 

for a sequence that contained a schedule constraint 

• Fixed an issue where incorrect results were generated by the Generate by 

Periods Form due to the pit mesh not being loaded beforehand and the 

metadata not being immediately queried from the mesh server 
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• Fixed an issue where activating a sequence before the mesh file was 

loaded in the CAD Window would result in digger appearing in an 

incorrect position 

• Fixed an issue where mesh numbers were still shown on a bench that was 

not set to Active in the Active Bench Option when running animation 

• Fixed an issue where unloading the mesh file from the CAD Window didn’t 

automatically remove the digger from the CAD Window 

• Fixed an issue where reordering sequence numbers did not automatically 

repositioned the digger position in the mining blocks 

• Fixed an issue where the Cancel Button to undo split block didn’t work 

• Fixed an issue where the animation showed incorrect sequence order 

when there were split blocks 

• Fixed an issue where the split block process showed the mesh number  

from the bench underneath 

• Fixed a crash that occurred when selecting an active bench after 

performing split block operation 

• Fixed an issue where a block number was still displayed after the 

animation had stopped running 

Underground Engineering 

• Fixed an issue in longwall creation where entering numbers with a decimal 

point only captured the digits after the decimal. For example, typing "30.5" 

would incorrectly take "5" as the input due to premature number 

formatting. 

• Fixed an issue where re-running underground reserves in the Run 

Reserves Form didn't completely overwrite existing metadata, leaving 

some outdated entries. Now, clicking OK or Apply will wipe all metadata 

and rewrite from the table file, except for the six metadata produced when 

creating UG mining blocks: RESTOPSURF, RESBOTSURF, BENCH, 

MATERIAL, UGBLOCKTYPE, and PANEL.  
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• Fixed an issue where reserving UG mining blocks with mesh not loaded in 

the CAD Window resulted in the output reserve table not having the 

Material Column 

• Fixed an issue where the SMAX Option in the Subsidence Group failed to 

run because it didn’t read the Grid spec from the Setup Option 

Plot Designer 

• Fixed an issue where resizing the viewport resulted in the title block 

container being resized because their positions were aligned 

• Fixed an issue where the Properties Dock didn’t update when switching to 

a different viewport 

• Fixed a crash that occurred after clicking the Preview & Print Button on a 

rapid plot file 

Archive and Recover Tool 

• Fixed an error where the Archive & Recover Tool couldn’t be started 

Pit Optimization Pro 

• Fixed the Add Region and Edit Region forms to make it easier to adjust 

the value of benches and block model counts (I, J, K) 

• Fixed an error that occurred when trying to run the optimization module in 

Run Optimization Node of the Pit Optimization Pro Form 

Removed 

• Removed the Like acceses mode Checkbox from the Filter Form 

• Removed the Run Reserves Option within the UG Solids Group of the UG 

Coal Tab. Users can now calculate reserves for the UG mining blocks by 

going to the Reserves Tab and click Run Reserves in the Reserves Group. 


